Insights Reporting Outage

Incident Report for WalkMe EU Status

Resolved

This incident has been resolved.
Posted 20 days ago. Jun 13, 2025 - 20:26 UTC

Monitoring

We are seeing that the issue is stabilizing and we are currently monitoring the results.
Posted 21 days ago. Jun 12, 2025 - 19:38 UTC
This incident affected: Data (Insights reports).